Browser Support in ScreenLight

In the time since we started developing ScreenLight there have been new browsers released and with them, new capabilities that can be used to deliver more ambitious applications to our users. While newer browsers support these capabilities in their fullest, older browsers offer at best partial support if any. Supporting older browsers takes a signficant amount of time to test for compatibility on different browsers and then develop hacks and workarounds when things aren't quite right.

Like any business we have to decide where to allocate our finite resources. Time spent tweaking the application to work around limitations of an older browser version is weighted against improving features or adding new ones. As we strive to make the application work in a consistent manner accross browsers, tablets, and smartphones, it doesn't make sense to offer a more limited version that works on old browsers. Nor does it make sense to develop for the lowest common denominator. Therefore we are dropping support for old browsers once usage by our customers falls below a minimum threshold.

This isn't much of an issue for people using Safari, Chrome, and Firefox, who represent approximately 35%, 21%, and 18% respectively of our application visits. These browsers either automatally update themselves or regularly prompt users to update them. As such, the number of people who use ScreenLight with out of date versions of these browsers is relatively insignificant. For example, less than 1% of ScreenLight visits are with a version of Firefox (below version 5) that does not support HTML5 video.

The tradeoff is most apparent with people using Internet Explorer. Unfortunately, Microsoft doesn't update its browsers nearly as freqeuntly as its competitors. This is compounded by the fact that until recently, Microsoft's browsers haven't automatically updated themselves to newer versions.

Internet Explorer did not add support for HTML5 and the video tag until IE9 (released March 2011). Supporting earlier versions is challenging. However, a look at our browser stats over the last three months, shows that approximately 12% of our visits are with IE8 (released March 2009), making it the most popular of all IE versions. Due to its relatively high usage, we have ensured that ScreenLight works properly with that browser.

Thankfully, browser usage for IE6 and IE7 has fallen below 3%. As such in didn't make sense to adapt the application to work with these browsers directly. Instead, we have decided prompt these users to install Google Chrome Frame before they can login to ScreenLight. Chrome Frame is a browser plugin that handles display in the browser. Essentially, it makes the browser work like a recent version of Google Chrome. This means that it supports HTML5.

Although it takes a few minutes and an operating system restart to install Chrome Frame, people do not need administrative rights to install it. This means that it will work in the locked down corporate IT environments where these old browsers are most prevalent. The plugin won't disrupt viewing of pages on other websites because it will only be used on sites like ScreenLight that request the use of Chrome Frame.

We decided not to force Chrome Frame on IE8 users because of the user experience. We want to keep the review process as simple as possible for users, and installing a plugin can be disruptive. Once IE8 usage falls into the 5% territory we'll reexamine whether it makes sense to force users to install Chrome Frame. This may unfortunately take some time, as IE9 and IE10 do not work with Windows XP.

Current ScreenLight browser support

  • Microsoft Internet Explorer 8.0+

  • Mozilla Firefox 5+

  • Google Chrome - recent versions

  • Apple Safari - recent versions